Vtp lab
Vtp lab
Konfigurasi:
1. Router:
Router>enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int f0/0
Router(config-if)#no shut
Router(config)#int f0/0.10
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip add 192.168.1.100 255.255.255.0
Router(config-subif)#int f0/0.20
Router(config-subif)#encaps dot1q 20
Router(config-subif)#ip add 192.168.2.100 255.255.255.0
Router(config-subif)#exit
2. SWITCH VTP (Server)
Switch>enable
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname IDN-SERVER
IDN-SERVER(config)#vlan 10
IDN-SERVER(config-vlan)#name SALES
IDN-SERVER(config-vlan)#vlan 20
IDN-SERVER(config-vlan)#name MARKETING
IDN-SERVER(config-vlan)#exit
IDN-SERVER(config)#int range f0/1-2
IDN-SERVER(config-if-range)#sw mode access
IDN-SERVER(config-if-range)#sw access vlan 10
IDN-SERVER(config-if-range)#exit
IDN-SERVER(config)#int range f0/3-4
IDN-SERVER(config-if-range)#sw mode access
IDN-SERVER(config-if-range)#sw access vlan 20
IDN-SERVER(config-if-range)#exit
IDN-SERVER(config)#int f0/5
IDN-SERVER(config-if)#sw mode trunk
IDN-SERVER(config-if)#sw trunk encaps dot1q
IDN-SERVER(config)#int f0/6
IDN-SERVER(config-if)#sw mode trunk
Membuat VTP Server
IDN-SERVER(config)#vtp mode server
Device mode already VTP SERVER.
IDN-SERVER(config)#vtp version 2
IDN-SERVER(config)#vtp domain idn.id
Domain name already set to idn.id
IDN-SERVER(config)#vtp password idn123
Setting device VLAN database password to idn123
3. SWITCH Lantai 1 VTP (Client)
Switch>enable
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname IDN-Lantai1
IDN-Lantai1(config)#int fa0/1
IDN-Lantai1(config-if)#sw mode trunk
IDN-Lantai1(config-if)#int fa0/4
IDN-Lantai1(config-if)#sw mode trunk
IDN-Lantai1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state
to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state
to up
Membuat VTP Client
IDN-Lantai1(config)#vtp mo client
Setting device to VTP CLIENT mode.
IDN-Lantai1(config)#vtp domain idn.id
Domain name already set to idn.id.
IDN-Lantai1(config)#vtp pass idn123
Setting device VLAN database password to idn123
4. SWITCH Lantai 2 VTP (Client)
Switch>enable
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname IDN-LANTAI2
IDN-LANTAI2(config)#int f0/1
IDN-LANTAI2(config-if)#sw mode trunk
Membuat VTP Client
IDN-LANTAI2(config-if)#vtp mo client
Setting device to VTP CLIENT mode.
IDN-LANTAI2(config)#vtp domain idn.id
Domain name already set to idn.id.
IDN-LANTAI2(config)#vtp pass idn123
Setting device VLAN database password to idn123
VERYFIKASI
SWITCH Lantai 1 (Client)
IDN-Lantai1(config)#do sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/2, Fa0/3, Fa0/5, Fa0/6
Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24
10 SALES active
20 MARKETING active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
Di atas VLAN 10 dan 20 sudah terSynkron, tinggal memasukkan Port interface pada VLAN tersebut sesuai dengan topology.
IDN-Lantai1(config)#int f0/2
IDN-Lantai1(config-if)#sw mode access
IDN-Lantai1(config-if)#sw access vlan 10
IDN-Lantai1(config-if)#int f0/3
IDN-Lantai1(config-if)#sw mode access
IDN-Lantai1(config-if)#sw access vlan 20
Sekarang coba tambahkan VLAN 30 (ADMINISTRATOR), 40 (MANAGER), 50 (EXECUTIVE) di SWITCH Server, maka lihat hasilnya pada SWITCH Lantai 2 (Client):
IDN-SERVER(config)#vlan 30
IDN-SERVER(config-vlan)#name ADMINISTRATOR
IDN-SERVER(config-vlan)#vlan 40
IDN-SERVER(config-vlan)#name MANAGER
IDN-SERVER(config-vlan)#vlan 50
IDN-SERVER(config-vlan)#name EXECUTIVE
SWITCH Lantai 2 (Client)
IDN-LANTAI2#sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24
10 SALES active
20 MARKETING active
30 ADMINISTRATOR active
40 MANAGER active
50 EXECUTIVE active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0
40 enet 100040 1500 - - - - - 0 0
50 enet 100050 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
Sudah langsung tersingkronkan pada VLAN 30, 40 dan 50, cek VTP Status;
IDN-LANTAI2#sh vtp status
VTP Version : 2
Configuration Revision : 6
Maximum VLANs supported locally : 255
Number of existing VLANs : 10
VTP Operating Mode : Client
VTP Domain Name : idn.id
VTP Pruning Mode : Disabled
VTP V2 Mode : Enabled
VTP Traps Generation : Disabled
MD5 digest : 0x1D0xAF0xED0x130xD50x250x120xFD
Configuration last modified by 0.0.0.0 at 3-1-93 00:58:53
Test Ping
PC2c ke PC1a
PC>ipconfig
FastEthernet0 Connection:(default port)
Link-local IPv6 Address.........: FE80::260:3EFF:FE52:4A58
IP Address......................: 192.168.2.3
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 192.168.2.100
PC>ping 192.168.1.1
Pinging 192.168.1.1 with 32 bytes of data:
Request timed out.
Reply from 192.168.1.1: bytes=32 time=0ms TTL=127
Reply from 192.168.1.1: bytes=32 time=1ms TTL=127
Reply from 192.168.1.1: bytes=32 time=0ms TTL=127
Ping statistics for 192.168.1.1:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms
Berikut ini diberikan contoh perintah untuk konfigurasi trunking pada port Fa0/1 pada sebuah switch.
Switch#configure terminal
Switch(config)#interface fa0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#end
Notes :
VTP mode itu ada 3: server, client, dan transparent
• Server = create, delete, modif vlan.
• Client = menerima konfigurasi vlan dan diterapkan ke dirinya sendiri.
• Transparent = menerima konfigurasi diberikan ke switch lain menerapkan ke dirinya sendiri (transparan).
• VTP domain maksudnya adalah untuk menerima vtp advertisement dari vtp server HARUS 1 domain.
Konfigurasi:
1. Router:
Router>enable
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int f0/0
Router(config-if)#no shut
Router(config)#int f0/0.10
Router(config-subif)#encapsulation dot1q 10
Router(config-subif)#ip add 192.168.1.100 255.255.255.0
Router(config-subif)#int f0/0.20
Router(config-subif)#encaps dot1q 20
Router(config-subif)#ip add 192.168.2.100 255.255.255.0
Router(config-subif)#exit
2. SWITCH VTP (Server)
Switch>enable
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname IDN-SERVER
IDN-SERVER(config)#vlan 10
IDN-SERVER(config-vlan)#name SALES
IDN-SERVER(config-vlan)#vlan 20
IDN-SERVER(config-vlan)#name MARKETING
IDN-SERVER(config-vlan)#exit
IDN-SERVER(config)#int range f0/1-2
IDN-SERVER(config-if-range)#sw mode access
IDN-SERVER(config-if-range)#sw access vlan 10
IDN-SERVER(config-if-range)#exit
IDN-SERVER(config)#int range f0/3-4
IDN-SERVER(config-if-range)#sw mode access
IDN-SERVER(config-if-range)#sw access vlan 20
IDN-SERVER(config-if-range)#exit
IDN-SERVER(config)#int f0/5
IDN-SERVER(config-if)#sw mode trunk
IDN-SERVER(config-if)#sw trunk encaps dot1q
IDN-SERVER(config)#int f0/6
IDN-SERVER(config-if)#sw mode trunk
Membuat VTP Server
IDN-SERVER(config)#vtp mode server
Device mode already VTP SERVER.
IDN-SERVER(config)#vtp version 2
IDN-SERVER(config)#vtp domain idn.id
Domain name already set to idn.id
IDN-SERVER(config)#vtp password idn123
Setting device VLAN database password to idn123
3. SWITCH Lantai 1 VTP (Client)
Switch>enable
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname IDN-Lantai1
IDN-Lantai1(config)#int fa0/1
IDN-Lantai1(config-if)#sw mode trunk
IDN-Lantai1(config-if)#int fa0/4
IDN-Lantai1(config-if)#sw mode trunk
IDN-Lantai1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state
to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/4, changed state
to up
Membuat VTP Client
IDN-Lantai1(config)#vtp mo client
Setting device to VTP CLIENT mode.
IDN-Lantai1(config)#vtp domain idn.id
Domain name already set to idn.id.
IDN-Lantai1(config)#vtp pass idn123
Setting device VLAN database password to idn123
4. SWITCH Lantai 2 VTP (Client)
Switch>enable
Switch#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname IDN-LANTAI2
IDN-LANTAI2(config)#int f0/1
IDN-LANTAI2(config-if)#sw mode trunk
Membuat VTP Client
IDN-LANTAI2(config-if)#vtp mo client
Setting device to VTP CLIENT mode.
IDN-LANTAI2(config)#vtp domain idn.id
Domain name already set to idn.id.
IDN-LANTAI2(config)#vtp pass idn123
Setting device VLAN database password to idn123
VERYFIKASI
SWITCH Lantai 1 (Client)
IDN-Lantai1(config)#do sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/2, Fa0/3, Fa0/5, Fa0/6
Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24
10 SALES active
20 MARKETING active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
Di atas VLAN 10 dan 20 sudah terSynkron, tinggal memasukkan Port interface pada VLAN tersebut sesuai dengan topology.
IDN-Lantai1(config)#int f0/2
IDN-Lantai1(config-if)#sw mode access
IDN-Lantai1(config-if)#sw access vlan 10
IDN-Lantai1(config-if)#int f0/3
IDN-Lantai1(config-if)#sw mode access
IDN-Lantai1(config-if)#sw access vlan 20
Sekarang coba tambahkan VLAN 30 (ADMINISTRATOR), 40 (MANAGER), 50 (EXECUTIVE) di SWITCH Server, maka lihat hasilnya pada SWITCH Lantai 2 (Client):
IDN-SERVER(config)#vlan 30
IDN-SERVER(config-vlan)#name ADMINISTRATOR
IDN-SERVER(config-vlan)#vlan 40
IDN-SERVER(config-vlan)#name MANAGER
IDN-SERVER(config-vlan)#vlan 50
IDN-SERVER(config-vlan)#name EXECUTIVE
SWITCH Lantai 2 (Client)
IDN-LANTAI2#sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24
10 SALES active
20 MARKETING active
30 ADMINISTRATOR active
40 MANAGER active
50 EXECUTIVE active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
30 enet 100030 1500 - - - - - 0 0
40 enet 100040 1500 - - - - - 0 0
50 enet 100050 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
Sudah langsung tersingkronkan pada VLAN 30, 40 dan 50, cek VTP Status;
IDN-LANTAI2#sh vtp status
VTP Version : 2
Configuration Revision : 6
Maximum VLANs supported locally : 255
Number of existing VLANs : 10
VTP Operating Mode : Client
VTP Domain Name : idn.id
VTP Pruning Mode : Disabled
VTP V2 Mode : Enabled
VTP Traps Generation : Disabled
MD5 digest : 0x1D0xAF0xED0x130xD50x250x120xFD
Configuration last modified by 0.0.0.0 at 3-1-93 00:58:53
Test Ping
PC2c ke PC1a
PC>ipconfig
FastEthernet0 Connection:(default port)
Link-local IPv6 Address.........: FE80::260:3EFF:FE52:4A58
IP Address......................: 192.168.2.3
Subnet Mask.....................: 255.255.255.0
Default Gateway.................: 192.168.2.100
PC>ping 192.168.1.1
Pinging 192.168.1.1 with 32 bytes of data:
Request timed out.
Reply from 192.168.1.1: bytes=32 time=0ms TTL=127
Reply from 192.168.1.1: bytes=32 time=1ms TTL=127
Reply from 192.168.1.1: bytes=32 time=0ms TTL=127
Ping statistics for 192.168.1.1:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms
Berikut ini diberikan contoh perintah untuk konfigurasi trunking pada port Fa0/1 pada sebuah switch.
Switch#configure terminal
Switch(config)#interface fa0/1
Switch(config-if)#switchport mode trunk
Switch(config-if)#end
Notes :
VTP mode itu ada 3: server, client, dan transparent
• Server = create, delete, modif vlan.
• Client = menerima konfigurasi vlan dan diterapkan ke dirinya sendiri.
• Transparent = menerima konfigurasi diberikan ke switch lain menerapkan ke dirinya sendiri (transparan).
• VTP domain maksudnya adalah untuk menerima vtp advertisement dari vtp server HARUS 1 domain.
Komentar
Posting Komentar